yet another blog about computer, technology, programming, and internet

Monday, September 10, 2007

PPPoE Problem: unavailable - device missing

Monday, September 10, 2007 Posted by Ismail Habib 33 comments
Last week I tried to make a new PPPoE connection to my campus. I did it before and everything went fine, but not last week. I couldn't do the dial and when I saw the dial-up icon this not-so-funny-message under the dial-up icon: unavailable - device missing. I went crazy for sometimes before I found this solution:

1. Download devcon.exe from some Microsoft sites

2. Open netrasa.inf in c:\windows\inf (c:\winnt\inf on win2k I guess)

3. Look for the section [Msft.NTx86]

4. In the DeviceID column, you can see the installable devices.

5. Run this command to install the WAN Miniport (PPTP):
devcon.exe install c:\windows\inf\netrasa.inf MS_PptpMiniport

6. Install the other devices similarly. (Probably you will need MS_L2tpMiniport, MS_PtiMiniport, MS_NdisWanIp, MS_PppoeMiniport additionally)

It worked. I didn't even bother to try to understand anything :P

Solution found at http://www.daniweb.com/forums/thread18016.html

33 comments:

  1. some on topic comment eh?
    hmmm, i dont even know whats PPPoE T_T

    so, yea, I'm glad that it worked, bib :D

    And it is kinda our habit as an instant generation i guess to not bothering about the "why" as long as it works ^^

    is that on-topic-comment enough? ^^;;>

    ReplyDelete
  2. Aldin8:53 PM

    Is bikin GB dong di blognya biar bisa ninggalin pesen pesen dengan mudah :p

    ReplyDelete
  3. Wiihhh.. Jadi klo ada masalah connection dr Roland, aku tinggal ke kamarmu lagi ya Bib, hehehe :D

    ReplyDelete
  4. jangan lupa aku menerapkan tarif konsultasi dalam hitungan menit looo...

    ReplyDelete
  5. "It worked. I didn't even bother to try to understand anything :P"


    bukannya itu yg selalu terjadi klo kita bekerja ama windows ???

    ReplyDelete